Apache-SSL < 1.3.23+1.46 i2d_SSL_SESSION Function SSL Client Certificate Overflow

This script is Copyright (C) 2002-2015 Tenable Network Security, Inc.

Synopsis :

The remote web server is vulnerable to a buffer overflow attack.

Description :

The remote host is using a version of Apache-SSL that is older than
1.3.22+1.46. Such versions are vulnerable to a buffer overflow that,
albeit difficult to exploit, may allow an attacker to execute
arbitrary commands on this host subject to the privileges under which
the web server operates.

See also :


Solution :

Upgrade to Apache-SSL version 1.3.23+1.47 or later. [Note that the
vulnerability was initially addressed in 1.3.23+1.46 but that version
had a bug.]

Risk factor :

High / CVSS Base Score : 7.5
CVSS Temporal Score : 5.5
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 10918 (apache_ssl_overflow.nasl)

Bugtraq ID: 4189

CVE ID: CVE-2002-0082