INN < 2.2.3 verifycancels Option Cancel Request Message Overflow

This script is Copyright (C) 2000-2011 Tenable Network Security, Inc.

Synopsis :

The remote host is affected by a remote buffer overflow vulnerability.

Description :

The remote version of INN is between 2.0 and 2.2.2

There is a known security flaw in this version of INN which
may allow an attacker to execute arbitrary code on this server
is the option 'verifycancels' is enabled in inn.conf

See also :

Solution :

Upgrade to version 2.2.3 or make sure that the option
verifycancel is disabled on this server.

Risk factor :

Low / CVSS Base Score : 3.6
CVSS Temporal Score : 3.1
Public Exploit Available : true

Family: Gain a shell remotely

Nessus Plugin ID: 10436 (innd_overflow.nasl)

Bugtraq ID: 1316

CVE ID: CVE-2000-0472