SSH CBC/CFB Data Stream Injection

This script is Copyright (C) 1999-2013 Tenable Network Security, Inc.


Synopsis :

The remote SSH server contains a cryptographical weakness that might allow
a third party to decrypt the traffic.

Description :

The remote host is running a version of SSH that is older than (or as old as)
version 1.2.23.

The remote version of this software is vulnerable to a known plain text attack,
which could allow an attacker to insert encrypted packets in the client - server
stream that will be deciphered by the server, thus allowing the attacker to
execute arbitrary commands on the remote server

Solution :

Upgrade to version 1.2.25 of SSH which solves this problem.

Risk factor :

Medium / CVSS Base Score : 5.1
(CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P)

Family: Misc.

Nessus Plugin ID: 10268 ()

Bugtraq ID:

CVE ID: CVE-1999-1085