Jenkins < 1.551 / 1.532.2 and Jenkins Enterprise 1.509.x / 1.532.x < 1.509.5.1 / 1.532.2.2 Multiple Vulnerabilities

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote web server hosts a job scheduling / management system that
is affected by multiple vulnerabilities.

Description :

The remote web server hosts a version of Jenkins or Jenkins Enterprise
that is affected by multiple vulnerabilities :

- A flaw in the Xstream library Jenkins uses for its XML
API could be utilized by a malicious user to execute
arbitrary code. (CVE-2013-7285)

- The CLI job creation functionality is affected by a
directory traversal vulnerability that could allow an
authenticated user to overwrite files and gain elevated
privileges.

- The Winstone servlet is vulnerable to session
hijacking.

- A session fixation vulnerability that could be exploited
by cookie tampering.

- Multiple information disclosure vulnerabilities.

- Multiple cross-site scripting vulnerabilities.
(CVE-2013-5573)

See also :

http://www.nessus.org/u?da47e3e2
http://www.nessus.org/u?87d02899

Solution :

Upgrade to Jenkins 1.551 / 1.532.2, Jenkins Enterprise 1.509.5.1 /
1.532.2.2 or later.

Risk factor :

High / CVSS Base Score : 9.0
(CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C)
CVSS Temporal Score : 9.0
(CVSS2#E:ND/RL:U/RC:C)
Public Exploit Available : true

Family: CGI abuses

Nessus Plugin ID: 72685 ()

Bugtraq ID: 64414
65694
65718
65720

CVE ID: CVE-2013-5573
CVE-2013-7285