Dell KACE K2000 < 3.3.52857 Multiple Vulnerabilities

This script is Copyright (C) 2014-2015 Tenable Network Security, Inc.


Synopsis :

The system deployment appliance detected on the remote host is
affected by multiple vulnerabilities.

Description :

The remote Dell KACE K2000 appliance is affected by multiple
vulnerabilities :

- The appliance stores the recovery account password in
plaintext within a PHP script. (CVE-2011-4046)

- The appliance can allow arbitrary command execution by
leveraging database write access. (CVE-2011-4047)

- An information disclosure vulnerability exists as the
appliance contains a default username and password for a
read-only reporting account. (CVE-2011-4048)

- The appliance's web interface is affected by multiple
cross-site scripting (XSS) vulnerabilities.
(CVE-2011-4436)

See also :

https://www.tenable.com/security/research/tra-2011-08
https://www.tenable.com/security/research/tra-2011-09
https://www.tenable.com/security/research/tra-2011-10
https://www.tenable.com/security/research/tra-2011-11
http://www.nessus.org/u?bbeb79e3

Solution :

Upgrade to version 3.3 SP1 (3.3.52857) or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.8
(CVSS2#E:F/RL:U/RC:ND)
Public Exploit Available : true

Family: CGI abuses

Nessus Plugin ID: 72416 ()

Bugtraq ID: 50605

CVE ID: CVE-2011-4046
CVE-2011-4047
CVE-2011-4048
CVE-2011-4436

Ready to Scan Unlimited IPs & Run Compliance Checks?

Upgrade to Nessus Professional today!

Buy Now

Combine the Power of Nessus with the Ease of Cloud

Start your free Nessus Cloud trial now!

Begin Free Trial