Synology DiskStation Manager < 4.3-3776 Update 2 Multiple Vulnerabilities

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Synology DiskStation Manager is affected by multiple
vulnerabilities.

Description :

According to its version number, the Synology DiskStation Manager
installed on the remote host is a version prior to 4.3-3776 Update 2.
It is, therefore, potentially affected by the following
vulnerabilities :

- An input validation error exists in the
'externaldevices.cgi' script that allows any
administrative user to execute arbitrary commands with
root privileges on the remote host.

- An input validation error exists in the 'wallpaper.cgi'
script that allows any authenticated user to download
arbitrary files.

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

http://seclists.org/fulldisclosure/2013/Sep/53

Solution :

Upgrade to 4.3-3776 Update 2 or later, or contact the vendor.

Risk factor :

High / CVSS Base Score : 7.1
(CVSS2#AV:N/AC:H/Au:S/C:C/I:C/A:C)
CVSS Temporal Score : 6.7
(CVSS2#E:F/RL:U/RC:ND)
Public Exploit Available : true

Family: CGI abuses

Nessus Plugin ID: 72343 ()

Bugtraq ID: 62310

CVE ID: