Firefox < 27.0 Multiple Vulnerabilities

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a web browser that is potentially
affected by multiple vulnerabilities.

Description :

The installed version of Firefox is earlier than 27.0 and is,
therefore, potentially affected by the following vulnerabilities :

- Memory issues exist in the browser engine that could
result in a denial of service or arbitrary code
execution. (CVE-2014-1477, CVE-2014-1478)

- An error exists related to System Only Wrappers (SOW)
and the XML Binding Language (XBL) that could allow
XUL content to be disclosed. (CVE-2014-1479)

- An error exists related to the 'open file' dialog that
could allow users to take unintended actions.
(CVE-2014-1480)

- An error exists related to the JavaScript engine and
'window' object handling that has unspecified impact.
(CVE-2014-1481)

- An error exists related to 'RasterImage' and image
decoding that could allow application crashes and
possibly arbitrary code execution. (CVE-2014-1482)

- Errors exist related to IFrames,
'document.caretPositionFromPoint' and
'document.elementFromPoint' that could allow cross-
origin information disclosure. (CVE-2014-1483)

- An error exists related to the Content Security
Policy (CSP) and XSLT stylesheets that could allow
unintended script execution. (CVE-2014-1485)

- A use-after-free error exists related to image handling
and 'imgRequestProxy' that could allow application
crashes and possibly arbitrary code execution.
(CVE-2014-1486)

- An error exists related to 'web workers' that could
allow cross-origin information disclosure.
(CVE-2014-1487)

- An error exists related to 'web workers' and 'asm.js'
that could allow application crashes and possibly
arbitrary code execution. (CVE-2014-1488)

- An error exists that could allow webpages to access
activate content from the 'about:home' page that
could lead to data loss. (CVE-2014-1489)

- Errors exist related to the included Network Security
Services (NSS) libraries, 'NewSessionTicket' handshakes
and public Diffie-Hellman values that could allow
application crashes and possibly arbitrary code
execution. (CVE-2014-1490, CVE-2014-1491)

See also :

http://www.zerodayinitiative.com/advisories/ZDI-14-058/
http://www.mozilla.org/security/announce/2014/mfsa2014-01.html
http://www.mozilla.org/security/announce/2014/mfsa2014-02.html
http://www.mozilla.org/security/announce/2014/mfsa2014-03.html
http://www.mozilla.org/security/announce/2014/mfsa2014-04.html
http://www.mozilla.org/security/announce/2014/mfsa2014-05.html
http://www.mozilla.org/security/announce/2014/mfsa2014-07.html
http://www.mozilla.org/security/announce/2014/mfsa2014-08.html
http://www.mozilla.org/security/announce/2014/mfsa2014-09.html
http://www.mozilla.org/security/announce/2014/mfsa2014-10.html
http://www.mozilla.org/security/announce/2014/mfsa2014-11.html
http://www.mozilla.org/security/announce/2014/mfsa2014-12.html
http://www.mozilla.org/security/announce/2014/mfsa2014-13.html

Solution :

Upgrade to Firefox 27.0 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false