memcached < 1.4.17 Multiple Vulnerabilities

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote host contains a memory-based object store that is
potentially affected by multiple vulnerabilities.

Description :

According to its self-reported version, the version of memcached
installed on the remote host is a version prior to 1.4.17. It is,
therefore, reportedly affected by the following vulnerabilities :

- An error exists related to handling SASL requests
that could allow authentication bypasses.
(CVE-2013-7239)

- An error exists in the function 'do_item_get' in the
file 'items.c' that could cause buffer overreads and
allow denial of service attacks. (CVE-2013-7290)

- An error related to logging and verbose mode could
allow some requests to cause denial of service
conditions. (CVE-2013-7291)

See also :

https://code.google.com/p/memcached/wiki/ReleaseNotes1417
http://seclists.org/oss-sec/2013/q4/572
http://www.nessus.org/u?d0080e1b
https://code.google.com/p/memcached/issues/detail?id=306

Solution :

Upgrade to memcached 1.4.17 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.5
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: General

Nessus Plugin ID: 72212 ()

Bugtraq ID: 64559
64988
64989

CVE ID: CVE-2013-7239
CVE-2013-7290
CVE-2013-7291