Google Chrome < 31.0.1650.63 Multiple Vulnerabilities (Mac OS X)

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host contains a web browser that is affected by
multiple vulnerabilities.

Description :

The version of Google Chrome installed on the remote Mac OS X host is
a version prior to 31.0.1650.63. It is, therefore, affected by the
following vulnerabilities :

- An error exists related to session fixation, the sync
process and HTTP 302 redirects. (CVE-2013-6634)

- A use-after-free error exists related to the editing
process. (CVE-2013-6635)

- An error exists related to modal dialogs that could
allow address spoofing. (CVE-2013-6636)

- Various unspecified errors exist having unspecified
impacts. (CVE-2013-6637)

- An out-of-bounds read error, an out-of-bounds write
error and a buffer overflow error exist in the v8
JavaScript engine. (CVE-2013-6638, CVE-2013-6639,
CVE-2013-6640)

See also :

http://www.nessus.org/u?cc90df4b

Solution :

Upgrade to Google Chrome 31.0.1650.63 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: MacOS X Local Security Checks

Nessus Plugin ID: 71228 ()

Bugtraq ID: 64078

CVE ID: CVE-2013-6634
CVE-2013-6635
CVE-2013-6636
CVE-2013-6637
CVE-2013-6638
CVE-2013-6639
CVE-2013-6640