Puppet Enterprise < 3.1.0 Multiple Vulnerabilities

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

A web application on the remote host is affected by multiple
vulnerabilities.

Description :

According to its self-reported version number, the Puppet Enterprise
install on the remote host is a version prior to 3.1.0. As a result,
it is reportedly affected by multiple vulnerabilities :

- An error exists related to the Fiddle and DL modules,
'$SAFE' level verification and object handling that
could allow an attacker to modify system calls.
(CVE-2013-2065)

- A remote code execution vulnerability exists that is
triggered when handling a YAML report. This could allow
a remote attacker to execute arbitrary code.
(CVE-2013-4957)

- A console account brute-force vulnerability exists that
could allow an attacker to brute-force a known user's
password. (CVE-2013-4965)

- A RubyGems algorithmic complexity denial of service
vulnerability exists that could allow an attacker to
cause a denial of service through CPU consumption.
(CVE-2013-4287)

See also :

http://puppetlabs.com/security/cve/cve-2013-2065
http://puppetlabs.com/security/cve/cve-2013-4957
http://puppetlabs.com/security/cve/cve-2013-4965
http://puppetlabs.com/security/cve/cve-2013-4287

Solution :

Upgrade to Puppet Enterprise 3.1.0 or later.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.9
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: CGI abuses

Nessus Plugin ID: 70684 ()

Bugtraq ID: 59881
62281
63173
63386

CVE ID: CVE-2013-2065
CVE-2013-4287
CVE-2013-4957
CVE-2013-4965