Apache mod_fcgid Module < 2.3.9 fcgid_header_bucket_read() Function Heap-Based Buffer Overflow

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote web server is affected by a buffer overflow
vulnerability.

Description :

According to its self-reported banner, the Apache web server listening
on this port includes a version of the mod_fcgid module earlier than
2.3.9. That reportedly has a heap-based buffer overflow vulnerability
because of an error in the pointer arithmetic used in the
'fcgid_header_bucket_read()' function.

See also :

http://www.mail-archive.com/dev@httpd.apache.org/msg58077.html
http://www.nessus.org/u?08112f11

Solution :

Update to version 2.3.9 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.5
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 70682 ()

Bugtraq ID: 62939

CVE ID: CVE-2013-4365