Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

PHP < 5.5.37, 5.6.23 Use-After-Free Remote Code Execution.

High

Synopsis

The specific version of PHP that the server is running is vulnerable to a user-after-free remote code execution.

Description

PHP contains a use-after-free error in the garbage collection algorithm in ext/spl/spl_array.c. This may allow a remote attacker to dereference already freed memory and potentially execute arbitrary code. Technical Information: This issue was introduced in version 5.3.0.

Note: Programming language vulnerability. This code is used in a wide variety of software and the issue may manifest in a number of different ways.

This issue is reportedly not exploitable in the 7.x branch, though it still appeared as fixed in version 7.0.8's changelog.

Solution

It has been reported that this has been fixed. Please refer to the product listing for upgraded versions that address this vulnerability.