icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Mac OS X : Safari < 6.0.4 SVG File Handling Arbitrary Code Execution

High

Synopsis

The remote host contains a web browser that is affected by a remote code execution vulnerability

Description

The remote Mac OS X host has Safari installed.

Versions of Safari earlier than 6.0.4 are reportedly affected by an arbitrary code execution vulnerability in WebKit related to handling SVG files that can be exploited by tricking a victim into visiting a specially crafted web page

Solution

Upgrade to Safari 6.0.4 or later.