icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Apache Tomcat 7.0.x < 7.0.20 'jsvc' Information Disclosure

Medium

Synopsis

The remote web server is affected by an information disclosure vulnerability.

Description

Versions of Tomcat 7.0.x earlier than 7.0.20 are potentially affected by an information disclosure vulnerability. A component that Apache Tomcat relies on called 'jsvc' contains an error in that it does not drop capabilities after starting and can allow access to sensitive files owned by the super user. Note that this vulnerability only affects Linux operating systems and only when the following are true :

- jsvc is compiled with libpcap.

- The '-user' parameter is used

Solution

Upgrade to Apache Tomcat 7.0.20 or later.