Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

OSX < 10.11.5 Multiple Vulnerabilities

High

Synopsis

The specific version of Mac OS X that the client is running has multiple vulnerabilities.

Description

The specific version of PHP that the system is running is reportedly affected by the following vulnerabilities:

- Apple Mac OS X contains an unspecified flaw in the Intel Graphics Driver. This may allow a local attacker to gain knowledge of kernel memory layout and in turn bypass security mechanisms like Kernel Address Space Layout Randomization (KASLR). Technical Information: By itself this issue has no real security impact. Combined with certain types of other vulnerabilities that allow code execution, this issue may make exploitation more reliable. (CVE-2016-1860)

- Apple Mac OS X contains an overflow condition in the NVIDIA Graphics Driver (GeForce.kext). This may allow a local attacker to cause a stack-based buffer overflow and potentially execute arbitrary code with kernel privileges.Technical Information: This issue was split out from VulnDB ID 138609, as it was assigned a separate CVE ID. (CVE-2016-1861)

- Apple Mac OS X contains an unspecified flaw in the Intel Graphics Driver. This may allow a local attacker to gain knowledge of kernel memory layout and in turn bypass security mechanisms like Kernel Address Space Layout Randomization (KASLR). (CVE-2016-1862)

Solution

It has been reported that this has been fixed. Please refer to the product listing for upgraded versions that address this vulnerability. In addition, the vendor has released Security Update 2016-003 for some older versions.