Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Bugzilla 4.4.x < 4.4.12 / 5.0.x < 5.0.3 Multiple XSS

Medium

Synopsis

The remote host is running a version of Bugzilla which is affected by multiple cross-site scripting (XSS) attack vectors.

Description

According to its banner, the version of Bugzilla running on the remote host is 4.4.x prior to 4.4.12, or 5.0.x prior to 5.0.3. These versions are affected by the following vulnerabilities :

- A flaw exists that allows a stored cross-site scripting (XSS) attack. This flaw exists because the 'showdependencygraph.cgi' script does not validate input to bug summaries before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server. (OSVDB 138615) - A flaw exists that allows a XSS attack. This flaw exists because the 'template/en/default/global/tabs.html.tmpl' script does not validate input to 'tab.link' before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server. (OSVDB 138616)

Solution

Upgrade to version 5.0.3. If 5.0.x cannot be obtained, 4.4.12 has also been patched for these vulnerabilities.