Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

HAProxy 1.5.x < 1.5.12 DoS

High

Synopsis

The remote host is running a version of HAProxy that is affected by a Denial of Service (DoS) attack vector.

Description

The installed version of HAProxy installed is version 1.5.x prior to 1.5.12, and is affected by an out-of-bounds read flaw in the 'http_replace_value()' function in 'proto_http.c' that may allow a remote attacker to cause a denial of service.

Solution

Upgrade to HAProxy version 1.5.12 or higher.