Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

MariaDB Server 10.2.x < 10.2.2 Multiple DoS

Medium

Synopsis

The remote database server is affected by multiple Denial of Service (DoS) attack vectors.

Description

The version of MariaDB installed on the remote host is 10.2.x prior to 10.2.2, and is affected by multiple DoS vulnerabilities :

- A NULL pointer flaw exists in the 'sync_array_cell_print()' function in 'storage/innobase/sync/sync0arr.cc' that may allow an authenticated attacker to crash the database. (OSVDB 144936) - A flaw exists in the 'Item::split_sum_func2()' function in 'sql/item.cc' that is triggered during the handling of 'SELECT' statements. This may allow an authenticated attacker to crash the database. (OSVDB 144946) - A flaw exists in the 'my_cop_fix_mb()' function that is triggered during the handling of queries for I_S and P_S tables. This may allow an authenticated attacker to crash the database. (OSVDB 144947) - A flaw exists in the 'Item_sum_sum::add_helper()' function in 'sql/sql_window.cc' that is triggered during the handling of 'RANGE' type frames. This may allow an authenticated attacker to crash the database. (OSVDB 144948) - A flaw exists in the 'With_clause::find_table_def()' function in 'sql/sql_cte.cc' that is triggered when handling a recursive view in 'SHOW CREATE VIEW'. This may allow an authenticated attacker to crash the database. (OSVDB 144949) - A flaw is triggered during the handling of an 'EXPLAIN + WITH' constant query. This may allow an authenticated attacker to crash the database. (OSVDB 144950) - A flaw exists in the 'Window_funcs_sort::setup()' function in 'sql/sql_window.cc' that is triggered during the handling of an 'OVER()' clause. This may allow an authenticated attacker to crash the database. (OSVDB 144951) - A flaw exists in the 'select_union_recursive::create_result_table()' function in 'sql/sql_union.cc' that is triggered during the handling of recursive definitions. This may allow an authenticated attacker to crash the database. (OSVDB 144953)

Solution

Upgrade to version 10.2.2 or later.