Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Oracle Java SE 6 < Update 115 / 7 < Update 101 / 8 < Update 92 Multiple Vulnerabilities

Critical

Synopsis

The remote host is missing a critical Oracle Java SE patch update.

Description

The version of Oracle Java SE installed on the remote host is prior to 6 Update 115, 7 Update 101, or 8 Update 92 and is affected by multiple vulnerabilities :

- An unspecified flaw related to the 'Serialization' subcomponent may allow a context-dependent attacker to execute arbitrary code. (CVE-2016-0686) - An unspecified flaw related to the 'Hotspot' subcomponent may allow a context-dependent attacker to execute arbitrary code. (CVE-2016-0687) - An unspecified flaw related to the 'Security' subcomponent may allow a remote attacker to gain access to potentially sensitive information. (CVE-2016-0695) - An unspecified flaw related to the '2D' subcomponent may allow a context-dependent attacker to cause a denial of service. (CVE-2016-3422) - An unspecified flaw related to the 'JAXP' subcomponent may allow a remote attacker to cause a denial of service. (CVE-2016-3425) - An unspecified flaw related to the 'JCE' subcomponent may allow a context-dependent attacker to gain access to potentially sensitive information. (CVE-2016-3426) - A flaw related to the 'JMX' subcomponent may allow a remote attacker to execute arbitrary code through Java deserialization. (CVE-2016-3427) - An out-of-bounds read flaw within the '2D' subcomponent is triggered when handling specially crafted files. This may allow a context-dependent attacker gain unauthorized access to potentially sensitive information. (CVE-2016-3443) - An unspecified flaw related to the 'Deployment' subcomponent may allow a context-dependent attacker to execute arbitrary code. (CVE-2016-3449)

Solution

Upgrade to Java 1.8.0_92 or later. If version 1.8.x cannot be obtained, versions 1.7.0_101 and 1.6.0_115 are also patched for these vulnerabilities.