Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

phpMyAdmin 4.4.x < 4.4.15.5 / 4.5.x < 4.5.5.1 Multiple XSS (PMASA-2016-12)

Low

Synopsis

The remote web server contains a PHP application that is affected by multiple cross-site scripting vulnerabilities.

Description

Versions of phpMyAdmin 4.4.x prior to 4.4.15.5, or 4.5.x prior to 4.5.5.1 are unpatched for multiple cross-site scripting (XSS) vulnerabilities. These attacks may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.

The following phpMyAdmin components are affected by these vulnerabilities : - A flaw which exists because the 'Database Normalization' page does not validate input when handling table or column names before returning it to users. (OSVDB 135209) - A flaw which exists because the 'Database Structure' page does not validate input when handling crafted parameters before returning it to users. (OSVDB 135210) - A flaw which exists because the 'Central Columns' page does not validate input when handling crafted parameters before returning it to users. (OSVDB 135211)

Solution

Upgrade to phpMyAdmin 4.5.5.1 or later. Alternatively, apply the patch referenced in the vendor advisory. If version 4.5.5.1 cannot be installed, version 4.4.15.5 is also patched for these vulnerabilities.