Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

phpMyAdmin 4.0.x < 4.0.10.15 / 4.4.x < 4.4.15.5 / 4.5.x < 4.5.5.1 Multiple XSS (PMASA-2016-11)

Medium

Synopsis

The remote web server contains a PHP application that is affected by multiple cross-site scripting vulnerabilities.

Description

Versions of phpMyAdmin 4.0.x prior to 4.0.10.15, 4.4.x prior to 4.4.15.5, or 4.5.x prior to 4.5.5.1 are unpatched for multiple cross-site scripting (XSS) vulnerabilities. These attacks may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.

The following phpMyAdmin components are affected by these vulnerabilities : - A flaw which exists because the 'User Accounts' page does not validate input before returning it to users. (OSVDB 135205) - A flaw which exists because the 'Zoom Search' page does not validate input before returning it to users. (OSVDB 135206) - A flaw which exists because the program does not validate input when handling URLs sent in the HOST header before returning it to users. (OSVDB 135207) - A flaw which exists because the program does not validate unspecified input when handling URLs before returning it to users. (OSVDB 135208)

Solution

Upgrade to phpMyAdmin 4.5.5.1 or later. Alternatively, apply the patch referenced in the vendor advisory. If version 4.5.5.1 cannot be installed, versions 4.4.15.5 and 4.0.10.15 are also patched for these vulnerabilities.