Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Samba 3.3.x < 3.3.11 / 3.4.x < 3.4.6 / 3.5.x < 3.5.0rc3 Directory Traversal

High

Synopsis

The remote Samba server is affected by a remote Denial of Service (DoS) attack vector.

Description

According to its banner, the version of Samba is 3.3.x earlier than 3.3.11, or 3.4.x earlier than 3.4.6, or 3.5.x earlier than 3.5.0rc3, and is therefore affected by a directory-traversal vulnerability as the application fails to sufficiently sanitize user-supplied input. According to the vendor, the issue stems from an insecure default configuration. The vendor advises administrators to set 'wide links = no' in the '[global]' section of 'smb.conf'. To exploit this issue, attackers require authenticated access to a writable share, and may be exploited through a writable share accessible by guest accounts. This may allow an attacker to access files outside of the Samba user's root directory to obtain sensitive information and perform other attacks.

Solution

Upgrade Samba to version 3.5.0rc3 or later. If version 3.5.x cannot be obtained, versions 3.4.6 and 3.3.11 have also been patched for this issue.