Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Samba 3.0.x versions 3.0.2 through 3.0.4 Buffer Overflow

Critical

Synopsis

The remote Samba server is affected by a buffer overflow attack vector.

Description

According to its banner, the version of Samba running on the remote host is between 3.0.2 and 3.0.4, inclusive. An error exists in the base64 decoding functions, which can result in a buffer overflow.

Solution

Upgrade Samba to version 3.0.5 or later.