Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

MariaDB Server 10.0.x < 10.0.22 / 10.1.x < 10.1.9 Multiple DoS Vulnerabilities

Medium

Synopsis

The remote database server is affected by multiple Denial of Service (DoS) attack vectors.

Description

MariaDB is a community-developed fork of the MySQL relational database. The version of MariaDB installed on the remote host is 10.0.x earlier than 10.0.22 or 10.1.x earlier than 10.1.9, and is therefore affected by the following denial of service vulnerabilities :

- A denial of service vulnerability exists due to a flaw in the 'ha_partition::index_init()' function that is triggered when handling the priority queue. An authenticated, remote attacker can exploit this, via a specially crafted query, to cause the database to crash. (OSVDB 129715) - A denial of service vulnerability exists due to a flaw in the 'Item_field::fix_outer_field()' function that is triggered when handling PREPARE statements. An authenticated, remote attacker can exploit this, via a specially crafted query, to cause the database to crash. (OSVDB 129716) - A denial of service vulnerability exists due to a flaw in the 'handle_grant_struct()' function that is triggered when handling HASH updates. An authenticated, remote attacker can exploit this, via a specially crafted query, to cause the database to crash. (OSVDB 129719) - A denial of service vulnerability exists due to a flaw in the 'is_invalid_role_name()' function that is triggered when handling ACLs with blank role names. An authenticated, remote attacker can exploit this, via a specially crafted query, to cause the database to crash. (OSVDB 129720) - A denial of service vulnerability exists due to a flaw in the 'Item_direct_view_ref' class that is triggered when handling SELECT queries. An authenticated, remote attacker can exploit this, via a specially crafted query, to cause the database to crash. (OSVDB 129721) - A denial of service vulnerability exists due to a flaw in the 'opt_sum_query()' function that is triggered when handling constant tables. An authenticated, remote attacker can exploit this, via a specially crafted query, to cause the database to crash. (OSVDB 129722)

Solution

Upgrade to version 10.1.9 or later. If version 10.1.x cannot be obtained, 10.0.22 is also patched for these issues.