Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

MariaDB Server 10.0.x < 10.0.23 / 10.1.x < 10.1.9 Multiple DoS Vulnerabilities

Medium

Synopsis

The remote database server is affected by multiple Denial of Service (DoS) attack vectors.

Description

MariaDB is a community-developed fork of the MySQL relational database. The version of MariaDB installed on the remote host is 10.0.x earlier than 10.0.23 or 10.1.x earlier than 10.1.9, and is therefore affected by the following denial of service vulnerabilities :

- A flaw exists in the 'check_fk_parent_table_access()' function in 'sql_parse.cc' that is triggered when performing database name conversions. This may allow an authenticated attacker to crash the database. (OSVDB 130734) - x (OSVDB 130783)

Solution

Upgrade to version 10.1.9 or later. If version 10.1.x cannot be obtained, 10.0.23 is also patched for these issues.