Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

MariaDB Server 10.1.x < 10.1.6 Multiple DoS Vulnerabilities

Medium

Synopsis

The remote database server is affected by multiple Denial of Service (DoS) attack vectors.

Description

MariaDB is a community-developed fork of the MySQL relational database. The version of MariaDB installed on the remote host is 10.1.x earlier than 10.1.6, and is therefore affected by the following denial of service vulnerabilities :

- A flaw exists in 'get_mm_leaf()' function in the 'sql/opt_range.cc' file that is triggered during the handling of xor statements in binary columns. This may allow an authenticated attacker to cause a crash. (OSVDB 125703) - A flaw exists in the 'filesort()' function that is triggered during the handling of ordered delete statements. This may allow an authenticated attacker to crash the database. (OSVDB 125704)

Solution

Upgrade to version 10.1.6 or later.