Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Bugzilla 2.6 < 4.2.16 / 4.3.1 < 4.4.11 / 4.5.1 < 5.0.2 Multiple XSS

Medium

Synopsis

The remote host is running a version of Bugzilla which is affected by multiple cross-site scripting (XSS) vulnerabilities.

Description

According to its banner, the version of Bugzilla running on the remote host falls within the range of 2.6 prior to 4.2.16, 4.3.1 prior to 4.4.11, or 4.5.1 prior to 5.0.2. Such versions are affected by the following vulnerabilities :

- A flaw exists that allows a stored cross-site scripting (XSS) attack. This flaw exists because the 'CreateImagemap()' function does not validate input during the generation of the dependency graph as HTML image maps are created locally. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server. (CVE-2015-8508) - A flaw exists that allows a cross-site scripting (XSS) attack. This flaw exists because the program does not validate input during buglist generation when parsing a crafted CSV file. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server. (CVE-2015-8509)

Solution

Upgrade to versions 4.2.16, 4.4.11, 5.0.2, or later.