Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

PostgreSQL 9.3 < 9.3.10 / 9.4 < 9.4.5 DoS

Medium

Synopsis

The database running on the remote server is affected by a denial of service vulnerability.

Description

The version of PostgreSQL installed on the remote host is 9.3.x prior to 9.3.10, or 9.4.x prior to 9.4.5 and is affected by a denial of service (DoS) vulnerability. This may allow an authenticated attacker to cause the server to crash when handling the specially crafted JSON request.

Solution

Upgrade to PostgreSQL 9.4.5, or later. If 9.4.x cannot be obtained, 9.3.10 is also patched for this vulnerability.