Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Zend Framework 1.x < 1.12.14 / 2.x < 2.4.6 / 2.5.x < 2.5.2 XXE Injection



The remote host is using a version of Zend Framework that is vulnerable to an XXE (Xml eXternal Entity) injection attack.


Versions of Zend Framework 1.x earlier than 1.12.14, 2.x earlier than 2.4.6, or 2.5.x earlier than 2.5.28 are vulnerable to an XXE (Xml eXternal Entity) injection flaw in ZendMXL that is triggered during the parsing of multibyte XML data. The issue is due to an incorrectly configured XML parser accepting XML external entities from an untrusted source. By sending specially crafted XML data, a remote attacker can gain unauthorized access to information or cause a denial of service.


Upgrade Zend Framework to version 2.5.2 or later. If version 2.5.x is not available, versions 2.4.6 and 1.12.14 are also patched for these vulnerabilities.