Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

PHP 5.5.x < 5.5.32 / 5.6.x < 5.6.18 / 7.0.x < 7.0.3 Multiple Vulnerabilities

Critical

Synopsis

The remote web server uses a version of PHP that is affected by multiple vulnerabilities.

Description

Versions of PHP 5.5.x prior to 5.5.32, or 5.6.x prior to 5.6.18, or 7.0.x prior to 7.0.3 are vulnerable to the following issues :

- The Perl-Compatible Regular Expressions (PCRE) library is affected by multiple vulnerabilities related to the handling of regular expressions, subroutine calls, and binary files. A remote attacker can exploit these to cause a denial of service, obtain sensitive information, or have other unspecified impact. (OSVDB 131055, OSVDB 131057, OSVDB 131059, OSVDB 131060, OSVDB 131062, OSVDB 131063, OSVDB 131064, OSVDB 131066, OSVDB 131067) - A flaw exists in file 'ext/standard/exec.c' in the 'escapeshellcmd()' and 'escapeshellarg()' functions due to the program truncating NULL bytes in strings. A remote attacker can exploit this to bypass restrictions. (OSVDB 134028) - A flaw exists in file 'ext/standard/streamsfuncs.c' in the 'stream_get_meta_data()' function due to a failure to restrict writing user-supplied data to fields not already set. A remote attacker can exploit this to falsify the output of the function, resulting in the insertion of malicious metadata. (OSVDB 134029) - A type confusion error exists in file 'ext/wddx/wddx.c' in the 'php_wddx_pop_element()' function when deserializing WDDX packets. A remote attacker can exploit this to have an unspecified impact. (OSVDB 134030) - A flaw exists in file 'ext/phar/phar_object.c' in the 'PharFileInfo::getContent()' method due to the use of uninitialized memory causing improper validation of user-supplied input. A remote attacker can exploit this to corrupt memory, resulting in a denial of service or the execution of arbitrary code. (OSVDB 134031) - A NULL pointer dereference flaw exists in file 'ext/phar/tar.c' in the 'phar_tar_setupmetadata()' function when parsing metadata from a crafted TAR file. A remote attacker can exploit this to cause a denial of service. (OSVDB 134032) - An integer overflow condition exists in file 'ext/standard/iptc.c' in the 'iptcembed()' function due to improper validation of user-supplied input. A remote attacker can exploit this to cause a heap-based buffer overflow, resulting in a denial of service or the execution of arbitrary code. (OSVDB 134033) - An overflow condition exists in file 'ext/phar/tar.c' in the 'phar_parse_tarfile()' function due to improper validation of user-supplied input when decompressing TAR files. A remote attacker can exploit this to cause a stack-based buffer overflow, resulting in a denial of service or the execution of arbitrary code. (OSVDB 134034) - A use-after-free error exists in 'SPL_METHOD(SplObjectStorage)' in 'ext/spl/spl_observer.c'. The issue is triggered when handling unserialize calls. This may allow a remote attacker to dereference already freed memory and potentially execute arbitrary code. (OSVDB 134035)

Solution

Upgrade to PHP version 7.0.3 or later. If 7.x cannot be obtained, 5.6.18 and 5.5.32 are also patched for these vulnerabilities.