Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Flash Player < 11.7.700.269 / 12.0.0.70 Multiple Vulnerabilities (APSB14-07)

High

Synopsis

The remote host is running an outdated version of Adobe Flash Player for Internet Explorer that is affected by multiple vulnerabilities.

Description

Versions of Adobe Flash player prior to 11.7.700.275 / 13.0.0.182 are outdated and thus unpatched for the following vulnerabilities :

- A stack overflow vulnerability exists that could result in arbitrary code execution. (CVE-2014-0498) - A memory leak vulnerability exists that could be used to aid in buffer overflow attacks by bypassing address space layout randomization (ASLR). (CVE-2014-0499) - A double free vulnerability exists that could result in arbitrary code execution. (CVE-2014-0502)

Solution

Upgrade to Adobe Flash Player version 12.0.0.70 or later. If 12.x cannot be obtained, 11.7.700.269 has also been patched for these vulnerabilities.