Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Mozilla Firefox < 36.0.4 / Firefox ESR < 31.5.3 SVG Bypass Privilege Escalation

High

Synopsis

The remote Windows host contains a web browser that is affected by a privilege escalation vulnerability.

Description

Versions of Mozilla Firefox earlier than 36.0.4 (or ESR version 31.5.3) are affected by a privilege escalation vulnerability due to a flaw within 'docshell/base/nsDocShell.cpp', which relates to SVG format content navigation. A remote attacker can exploit this to bypass same-origin policy protections, allowing a possible execution of arbitrary scripts in a privileged context.

Solution

Upgrade to Firefox 36.0.4 (or Firefox ESR version 31.5.3, as appropriate), or later.