Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

MyBB < 1.6.13 Multiple Vulnerabilities

Medium

Synopsis

The remote web server is running a PHP application that is vulnerable to multiple attack vectors.

Description

The remote web server hosts MyBulletinBoard, a web-based discussion board application. Versions of MyBB 1.6.x prior to 1.6.13 are potentially affected by multiple issues :

- Prone to a cross-site scripting vulnerability due to the lack of user-sanitized input submitted to the 'keywords' parameter of the '/Upload/search.php' script.(CVE-2014-1840)

- An unspecified flaw in the random string generator which results in insufficient random strings.

- A flaw affecting the language files could allow an attacker to execute arbitrary PHP code.

- A flaw affecting the stylesheets could allow an attacker to execute arbitrary PHP code.

Solution

Upgrade to MyBB 1.6.13 or later.