Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

phpMyAdmin 4.0.x < 4.0.10.4 / 4.1.x < 4.1.14.5 / 4.2.x < 4.2.9.1 Multiple XSS (PMASA-2014-11)

Medium

Synopsis

The remote web server contains a PHP application that is affected by multiple cross-site scripting vulnerabilities.

Description

Versions of phpMyAdmin earlier than 4.0.10.4, 4.1.14.5, and 4.2.9.1 are unpatched for cross-site scripting vulnerabilities affecting the table search and table structure pages. These vulnerabilities can be leveraged to steal cookie-based authentication, among other potential attacks, though note that they can only be leveraged by a logged-in user.

Solution

Either upgrade to phpMyAdmin 4.0.10.4, 4.1.14.5, 4.2.9.1 or later, or apply the patches from the referenced links.