Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

IBM WebSphere Application Server 8.5.5.x < 8.5.5.5 Multiple Vulnerabilities

High

Synopsis

The remote host is running an application server that is vulnerable to multiple attack vectors.

Description

The remote host appears to be running IBM WebSphere Application Server 8.5.5.x prior to 8.5.5.5. Such versions are potentially affected by multiple issues :

- A flaw exists in the SNMP capability that is triggered when handling configuration data that may allow an authenticated remote attacker to gain access to potentially sensitive information. (CVE-2015-0174) - An unspecified flaw exists in the liberty profile that is triggered when handling authData elements. This may allow an auhenticated remote attacker to gain elevated privileges. (CVE-2015-0175) - A flaw exists in the liberty profile that is triggered as the run-as user for EJB is not honored under multi-threaded race conditions. This may allow an authenticated remote attacker to gain elevated privileges. (CVE-2015-1882)

Solution

Upgrade WebSphere Application Server to 8.5.5.5 or later.