Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Oracle MySQL Server 5.1 < 5.1.63 Multiple Vulnerabilities

High

Synopsis

The remote database server is vulnerable to multiple attack vectors.

Description

The version of MySQL 5.1 installed on the remote host is earlier than 5.1.63 and is, therefore, affected by the following vulnerabilities :

- Several errors exist related to 'GIS Extension' and 'Server Optimizer' components that can allow denial of service attacks. (CVE-2012-0540, CVE-2012-1689, CVE-2012-1734)

- A security bypass vulnerability exists that occurs due to improper casting during user login sessions. (Bug #64884 / CVE-2012-2122)

- An error exists related to key length and sort order index that can lead to application crashes. (Bug #59387 / CVE-2012-2749

Solution

Upgrade to MySQL Server 5.1.63 later