Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Flash Player < 10.3.183.20 / 11.3.300.257 Multiple Vulnerabilities (APSB12-14)

High

Synopsis

The remote host contains a browser plugin that is affected by multiple vulnerabilities

Description

Versions of Flash Player earlier than 10.3.189.19 / 11.3.300.256 are potentially affected by multiple vulnerabilities :

- Multiple memory corruption vulnerabilities exist that could lead to code execution. (CVE-2012-2034, CVE-2012-2037) - A stack overflow vulnerability exists that could lead to code execution. (CVE-2012-2035) - An integer overflow vulnerability exists that could lead to code execution. (CVE-2012-2036) - A security bypass vulnerability exists that could lead to information disclosure. (CVE-2012-2038) - A null dereference vulnerability exists that could lead to code execution. (CVE-2012-2039) - A binary planting vulnerability exists in the Flash Player installer that could lead to code execution.(CVE-2012-2040)

Solution

Upgrade to Flash Player 10.3.183.20 / 11.3.300.257 or later.