Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Drupal Ubercart Module < 5.x-1.10 / 6.x-2.4 Multiple Vulnerabilities

High

Synopsis

The remote web server is hosting a web application that is affected by an authentication bypass vulnerability.

Description

The remote web server hosts a Drupal install that uses the Ubercart, an e-commerce module for Drupal CMS.

Versions of Ubercart earlier than 5.x-1.10 / 6.x-2.4 are potentially affected by multiple vulnerabilities :

- The 2Checkout gateway module does not properly verify payment notification information. Note that this module must be enabled for the Drupal install to be affected.

- The Paypal module's WPS payment method does not properly verify the payment notification information. Note that this module must be enabled for the Drupal install to be affected.

- The Ubercart Cart Links module is vulnerable to both an Access Bypass and Cross Site Request Forgery where a malicious user can trick other users into adding or removing items from their cart and add items to a cart which are not published on the site. Note that this module must be enabled for the Drupal install to be affected.

Solution

Upgrade to Drupal Ubercart Module 5.x-1.10 / 6.x-2.4 or later.