Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Moodle < 1.8.11 / 1.9.x < 1.9.7 Multiple Vulnerabilities

High

Synopsis

The remote web server is hosting a web application that is vulnerable to multiple attack vectors.

Description

The version of Moodle installed on the remote host is potentially vulnerable to multiple flaws.

- Multiple cross-site request forger issues. (MSA-09-0022)

- User account disclosure in LAMS module. (MSA-09-0023)

- Insufficient access control may allow unauthorized users to view glossary entries. (MSA-09-0024)

- Invalid application access control in MNET interface could allow execution of any MNET function from all registered remote servers. (MSA-09-0026)

- Login information can be sent unsecured even when a site is configured to use SSL for logins. (MSA-09-0027)

- A SQL injection issue in the SCORM module. (MSA-09-0031)

Solution

Upgrade to Moodle version 1.8.11, 1.9.7, or later.