Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

IBM WebSphere Application Server < 6.1.0.27 Multiple Vulnerabilities

Medium

Synopsis

The remote host is running a web server that is vulnerable to multiple attack vectors.

Description

IBM WebSphere Application Server 6.1.0 before Fix Pack 27 appears to be running on the remote host. Such versions are potentially affected by multiple issues :

- Eclipse help system included with WebSphere Application Server is affected by a cross-site scripting vulnerability. (PK78917)

- It may be possible to bypass security restrictions using a specially crafted HTTP HEAD method. (PK83258)

- New applications deployed in WebSphere Application Server for z/OS prior to 1.8 are saved on the file system with insecure privileges resulting in disclosure of sensitive information. (PK83308)

- If JAAS-J2C Authentication Data is configured using wsadmin scripts, the password value may appear in FFDC logs. (PK86137)

- Apache APR-util is affected by a denial of service issue. (PK88341)

- Due to an error in expat XML parser APR-util is affected by a denial of service issue. (PK88342)

- It may be possible to trigger a denial of service attack due to errors in fix packs 6.1.0.23 and 6.1.0.25. (PK91709)

Solution

Apply Fix Pack 27 (6.1.0.27) or later.