Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

QuickTime < 7.6.2 Multiple Vulnerabilities

Medium

Synopsis

The remote host contains an application that is vulnerable to multiple attack vectors.

Description

The version of QuickTime installed on the remote host is older than 7.6.2. Such versions contain multiple vulnerabilities :

- A memory corruption issue exists in QuickTime's handling of 'Sorenson 3' video files. (CVE-2009-0188)

- A heap buffer overflow exists in the handling of 'FLC' compression files. (CVE-2009-0951)

- A buffer overflow may occur when processing compressed 'PSD' images. (CVE-2009-0952)

- An integer overflow exists in the handling of 'PICT' images could lead to a heap buffer overflow. (CVE-2009-0010), (CVE-2009-0953)

- A heap buffer overflow could occur when handling 'Clipping Region' atom types in a movie file. (CVE-2009-0954)

- A heap buffer overflow exists in the handling of 'MS ADPCM' encoded audio data. (CVE-2009-0185)

- A sign extension issue exists in the handling of image description atoms. (CVE-2009-0955)

- An uninitialized memory access issue exists when handling movie files with a zero user data atom size. (CVE-2009-0956)

- A heap buffer overflow exists in the handling of 'JP2' images. (CVE-2009-0957)

Solution

Upgrade to QuickTime 7.6.2 or later.