Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

BEA WebLogic < 8.1.0 SP6 MBeanHome Config Information Disclosure

Medium

Synopsis

The remote host is vulnerable to a flaw that allows attackers to retrieve sensitive files.

Description

The remote host is running a version of BEA WebLogic Server or WebLogic Express that is prone to a flaw in the way that it handles anonymous RMI connections. An attacker exploiting this flaw would be able to retrieve sensitive configuration files anonymously. Such information would undoubtedly aid the attacker in more sophisticated attacks.

Solution

Upgrade to version 8.1.0 SP6 or higher.