Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

BXCP < 0.2.9.8 index.php show Parameter PHP Content Disclosure

Medium

Synopsis

The remote host is vulnerable to a flaw that allows attackers to retrieve sensitive files or data.

Description

The remote host is running BXCP. BXCP is a web application which does content management. There is a flaw in this version of BXCP that would allow an attacker to view the source code (or content) of any PHP script on the system. The flaw is due to how the index.php script handles the 'show' parameter. An attacker exploiting this flaw would be able to use a '../../' directory traversal syntax within the 'show' parameter, thereby rendering the code of any PHP script on the system.

Solution

Upgrade to 0.2.9.8 or higher.