Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Xine-lib < 1.0 RC6a Heap and Stack Overflows

Medium

Synopsis

The remote host is vulnerable to multiple buffer overflows.

Description

The remote host is using a software linked again xine-lib, an open-source multimedia library. It is reported that versions up to 1.0 rc6a are vulnerable to multiple overflows in the DVD, subtitles and Video-CD modules. An attacker may craft a malicious multimedia file that may execute arbitrary code on the remote host if played with a xine-lib based software.

Solution

Upgrade to Xine-lib 1.0 RC6a or higher.