Codesys Control Improper Input Validation

high Tenable.ot Plugin ID 500450
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

CODESYS Control Runtime system before 3.5.17.0 has improper input validation. Attackers can send crafted communication packets to change the router's addressing scheme and may re-route, add, remove or change low level communication packages.

Solution

Refer to vendor advisory for Security Updates

See Also

https://customers.codesys.com/index.php

https://www.codesys.com/security/security-reports.html

https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=14640&token=623b6fceb0579ef0f7505e29beefa5b3f8ac7873&download=

Plugin Details

Severity: High

ID: 500450

Version: 1.0

Type: local

Family: SCADA

Published: 8/10/2021

Updated: 8/10/2021

Risk Information

CVSS Score Source: CVE-2021-29242

CVSS v2

Risk Factor: High

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3

Risk Factor: High

Base Score: 7.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Vulnerability Information

CPE: cpe:2.3:a:codesys:control_for_beaglebone_sl:*:*:*:*:*:*:*:*, cpe:2.3:a:codesys:control_for_empc-a\/imx6_sl:*:*:*:*:*:*:*:*, cpe:2.3:a:codesys:control_for_iot2000_sl:*:*:*:*:*:*:*:*, cpe:2.3:a:codesys:control_for_linux_sl:*:*:*:*:*:*:*:*, cpe:2.3:a:codesys:control_for_pfc100_sl:*:*:*:*:*:*:*:*, cpe:2.3:a:codesys:control_for_pfc200_sl:*:*:*:*:*:*:*:*, cpe:2.3:a:codesys:control_for_raspberry_pi_sl:*:*:*:*:*:*:*:*, cpe:2.3:a:codesys:gateway:*:*:*:*:*:*:*:*, cpe:2.3:a:codesys:opc_server:*:*:*:*:*:*:*:*, cpe:2.3:a:codesys:plchandler:*:*:*:*:*:*:*:*, cpe:2.3:a:codesys:control_rte:*:*:*:*:*:*:*:*, cpe:2.3:a:codesys:control_win:*:*:*:*:*:*:*:*, cpe:2.3:a:codesys:embedded_target_visu_toolkit:*:*:*:*:*:*:*:*, cpe:2.3:a:codesys:hmi:*:*:*:*:*:*:*:*, cpe:2.3:a:codesys:remote_target_visu_toolkit:*:*:*:*:*:*:*:*, cpe:2.3:a:codesys:simulation_runtime:*:*:*:*:*:*:*:*, cpe:2.3:a:codesys:control_rte:*:*:*:*:*:beckhoff_cx:*:*, cpe:2.3:a:codesys:edge_gateway:*:*:*:*:*:linux:*:*, cpe:2.3:a:codesys:edge_gateway:*:*:*:*:*:windows:*:*, cpe:2.3:a:codesys:conrol_runtime_system_toolkit:*:*:*:*:*:*:*:*, cpe:2.3:a:codesys:control_for_linux_arm_sl:*:*:*:*:*:*:*:*, cpe:2.3:a:codesys:control_for_plcnext_sl:*:*:*:*:*:*:*:*, cpe:2.3:a:codesys:control_for_wago_touch_panels_600_sl:*:*:*:*:*:*:*:*, cpe:2.3:a:codesys:safety_sil:*:*:*:*:*:*:*:*

Patch Publication Date: 5/3/2021

Vulnerability Publication Date: 5/3/2021

Reference Information

CVE: CVE-2021-29242