openSUSE Security Update : libsatsolver (libsatsolver-266)

High Nessus Plugin ID 40043


The remote openSUSE host is missing a security update.


A remotely exploitable code execution vulnerability via shell metachars has been fixed in libzypp.


Update the affected libsatsolver packages.

See Also

Plugin Details

Severity: High

ID: 40043

File Name: suse_11_0_libsatsolver-081021.nasl

Version: $Revision: 1.7 $

Type: local

Agent: unix

Published: 2009/07/21

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libsatsolver-devel, p-cpe:/a:novell:opensuse:libsatsolver-perl, p-cpe:/a:novell:opensuse:libsatsolver-ruby, p-cpe:/a:novell:opensuse:libzypp, p-cpe:/a:novell:opensuse:libzypp-devel, p-cpe:/a:novell:opensuse:satsolver-tools, cpe:/o:novell:opensuse:11.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/10/21