openSUSE 10 Security Update : kdelibs4 (kdelibs4-5220)

High Nessus Plugin ID 32180


The remote openSUSE host is missing a security update.


A heap overflow in the PNG loader of KHTML has been fixed.
CVE-2008-1670 has been assigned to this issue.


Update the affected kdelibs4 packages.

Plugin Details

Severity: High

ID: 32180

File Name: suse_kdelibs4-5220.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2008/05/09

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:kdelibs4, p-cpe:/a:novell:opensuse:kdelibs4-core, p-cpe:/a:novell:opensuse:libkde4, p-cpe:/a:novell:opensuse:libkde4-32bit, p-cpe:/a:novell:opensuse:libkde4-devel, p-cpe:/a:novell:opensuse:libkdecore4, p-cpe:/a:novell:opensuse:libkdecore4-32bit, p-cpe:/a:novell:opensuse:libkdecore4-devel, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/04/28

Reference Information

CVE: CVE-2008-1670

CWE: 119