openSUSE 10 Security Update : clamav (clamav-3540)

High Nessus Plugin ID 27182


The remote openSUSE host is missing a security update.


This update of ClamAV fixes several security bugs.

- wrong calculation of buffer-end

- use strict permissions for temporary files

- heap corruption causing denial-of-service with corrupted rar archive

- detect block list loop


Update the affected clamav package.

Plugin Details

Severity: High

ID: 27182

File Name: suse_clamav-3540.nasl

Version: $Revision: 1.9 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:clamav, cpe:/o:novell:opensuse:10.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/06/05