MDKA-2007:009 : perl-SOAP-Lite

High Nessus Plugin ID 24546


The remote Mandrake host is missing one or more security-related patches.


SOAP::Lite makes use of auto-generated methods with names that clash with methods exported by UNIVERSAL::require. As a result, using the two modules simultaneously will result in an immediate program crash.

The package has been patched with an upstream fix to correct the issue.


Update the affected package(s).

See Also

Plugin Details

Severity: High

ID: 24546

File Name: mandrake_MDKA-2007-009.nasl

Version: $Revision: 1.9 $

Type: local

Published: 2007/02/18

Modified: 2012/09/07

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: cpe:/o:mandriva:linux

Required KB Items: Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2007/01/15