Apache < 2.2.15 Multiple Vulnerabilities

High Log Correlation Engine Plugin ID 800554

Synopsis

The remote web server is vulnerable to multiple attack vectors.

Description

According to its banner, the version of Apache 2.2 installed on the remote host is older than 2.2.15. Such versions are potentially affected by multiple vulnerabilities :

- A TLS renegotiation prefix attack is possible. (CVE-2009-3555)

- The 'mod_proxy_ajp' module returns the wrong status code if it encounters an error which causes the back-end server to be put into an error state. (CVE-2010-0408)

- The 'mod_isapi' module attempts to unload the 'ISAPI.DLL' when it encounters various error states which could leave call-backs in an undefined state. (CVE-2010-0425)

- A flaw in the core sub-request process code can lead to sensitive information from a request being handled by the wrong thread if a multi-threaded environment is used. (CVE-2010-0434)

IAVA Reference : 2011-A-0107
IAVB Reference : 2012-B-0038
STIG Finding Severity : Category I

Solution

Either ensure the affected module is not in use or upgrade to Apache version 2.2.15 or later.

See Also

httpd.apache.org/security/vulnerabilities_22.html

https://issues.apache.org/bugzilla/show_bug.cgi?id=48359

http://www.apache.org/dist/httpd/CHANGES_2.2.15

Plugin Details

Severity: High

ID: 800554

File Name: 800554.prm

Family: Web Servers

Published: 2010/03/08

Nessus ID: 42880, 45004

Risk Information

Risk Factor: High

CVSSv2

Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2010/03/08

Vulnerability Publication Date: 2010/03/03

Exploitable With

Core Impact

Reference Information

CVE: CVE-2009-3555, CVE-2010-0408, CVE-2010-0425, CVE-2010-0434

BID: 36935, 38491, 38494, 38580